/ Alert

A powerful and easy-to-use alerting library for Flutter

A powerful and easy-to-use alerting library for Flutter

Flash

A highly customizable, powerful and easy-to-use alerting library for Flutter.

Specs

This library allows you to show messages or alerts in your app quickly
and easily
. It can be used as an alternative to Snackbar or Toast
or Dialog and offers a plethora of useful features and customization
options for you to play with.

It has been written 100% in Dart. ❤️

flasah

Getting started

In the pubspec.yaml of your flutter project, add the following
dependency:

dependencies:
  ...
  flash: "^1.1.0"

In your library add the following import:

import 'package:flash/flash.dart';

Sample Project

We have an exhaustive sample project demonstrating almost
every feature of the library.

Usage

It is recommended to check the sample project to get a complete
understanding of all the features offered by the library.

basic
top
bottom
toast
dialog

Roadmap

These are some of the prioritized features in the pipeline awaiting to
be implemented in the near future

Contribution

I highly encourage the community to step forward and improve this
library further. You can fix any reported bug, propose or implement new
features, write tests, etc.

Here is a quick list of things to remember

  • Check the open issues before creating a new one,
  • Help me in reducing the number of open issues by fixing any existing
    bugs,
  • Check the roadmap to see if you can help in implementing any new
    feature,
  • You can contribute by writing unit and integration tests for this
    library,
  • If you have any new idea that aligns with the goal of this library,
    feel free to raise a feature request and discuss it.

GitHub